Thread Rating:
  • 5 Vote(s) - 3.8 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 10 Sleep and Monitor Wakeup Problems
#1
You are no doubt reading this because your monitor/s don’t wake up properly after your PC enters Sleep mode or tries to come out of “Turn off Display Mode” (Turn off Display after a set period of time).

You can either disable Sleep Mode entirely or, if that is not an option for you, set advanced Power Options as follows:

Open “Power Options” and select “Change Plan Settings” then “Change Advanced Power Settings”.
Under “PCI Express” set “Link State Power Management” to “Off” – this is the main culprit.

You may also want to turn off (Disable) “USB selective suspended setting” if you find that the USB Mouse or Keyboard doesn’t respond to input.

While everyone is in favour of saving power, extending the longevity of hardware or protecting your privacy when you are away from your PC, you will no doubt encounter issues with Windows 10 with either Sleep of “Turn off Monitor” Modes.

Personally, I choose never to put my PC to Sleep and rather prefer to Turn off the monitor after a pre-set time. My reasons are clear in that I have critical monitoring software installed that “stalls” when the PC enters Sleep Mode.

Figure out what will work for you – I mostly find that having both Sleep Mode and “Turn off Display” creates a headache when it comes to waking up my 3 monitors.


Forum Jump:


Users browsing this thread: 1 Guest(s)